BUG: High system cpu on Mac version ?

Post Reply
User avatar
MadDog_IL
Active Poster
Posts: 50
Joined: Sat Sep 06, 2003 5:15 pm

BUG: High system cpu on Mac version ?

Post by MadDog_IL » Tue Oct 13, 2009 2:14 pm

hey,

Posted this also on HWS3 section, not sure this was right section for it...

Today i purchased a separate license for mac, so i can run a copy on my new macbook air.
I came across problem that for some unknown reason when playing game, at some point in the game where some "stacks" are already piled up, the cpu usage (both user & system) becomes very high. the process itself gets up to 20-35% and system cpu shows as total of 80%.
When HWS3 closed, the system % usage is down back to 5%.

I'm currently running Mac OS X 10.5.8 (waiting for snow leopard mail shipment for upgrade, should arrive tomorrow).
Running with MacBook Air 1.6GHz, 2gb ram.

Would appreciate a fix for the problem, as i cannot play with this bg, it's major slow down to system, mouse cursor itself begin to be sluggish and i cannot use my mac or even play like this :(

User avatar
Jonas
Illuminated One
Illuminated One
Posts: 5002
Joined: Mon Nov 25, 2002 3:46 pm
Contact:

Re: BUG: High system cpu on Mac version ?

Post by Jonas » Tue Oct 13, 2009 4:04 pm

Hrmm thats odd.

Try playing with the graphics options in the game, for instance turning off or on Enhanced mode.

User avatar
MadDog_IL
Active Poster
Posts: 50
Joined: Sat Sep 06, 2003 5:15 pm

Re: BUG: High system cpu on Mac version ?

Post by MadDog_IL » Wed Oct 14, 2009 4:53 am

I've tried it.
if i turn "enhanced mode" OFF then display goes wierd at all,
strange flickering all over.

EDIT: i got the upgrade for OS X 10.6 (snow leopard).
I will install it tonight, if problem will be solved, i will notify about it here...

User avatar
MadDog_IL
Active Poster
Posts: 50
Joined: Sat Sep 06, 2003 5:15 pm

Re: BUG: High system cpu on Mac version ?

Post by MadDog_IL » Thu Oct 15, 2009 7:56 am

Seems the upgrade to snow leopard somehow solved it.
If no issues will shown guess that solved it.

User avatar
Jonas
Illuminated One
Illuminated One
Posts: 5002
Joined: Mon Nov 25, 2002 3:46 pm
Contact:

Re: BUG: High system cpu on Mac version ?

Post by Jonas » Fri Oct 30, 2009 3:18 pm

That's good news, thanks for passing it along.

Post Reply