Graphics flaw in latest release of Backgammon for OS X

Post Reply
Kurt Lang
Active Poster
Posts: 35
Joined: Fri Dec 03, 2004 12:51 pm

Graphics flaw in latest release of Backgammon for OS X

Post by Kurt Lang » Mon Jun 26, 2006 1:05 pm

The latest release, .1 of April 20, 2006 introduced a graphics bug. The first game appears normal. All subsequent games randomly turns some, but not all of the stones flat (they lose their 3-D appearance). You also see small black lines radiating from center around the mouse when you are dragging a stone.

User avatar
Jonas
Illuminated One
Illuminated One
Posts: 4988
Joined: Mon Nov 25, 2002 3:46 pm
Contact:

Post by Jonas » Mon Jun 26, 2006 2:28 pm

what Mac and OS version are you running?

Is anyone else have a simaler experiance?

Kurt Lang
Active Poster
Posts: 35
Joined: Fri Dec 03, 2004 12:51 pm

Actually, graphics issues in all games now.

Post by Kurt Lang » Mon Jun 26, 2006 2:41 pm

Saw that there were new versions of each game for OS X (Hearts, Spades, Euchre and Solitaire). Downloaded the patch for each one and installed them.

All games now have jerky, somewhat pixelized graphics. The following two images are from version 2.5. The first is build 77, the second is build 80.

Image

Image

Note that the arc of the cards is shallower. They are also uneven in the height in relation to the arc. More, the cards are skewed to a parallelogram shape rather than having 90º corners. The games have also all lost their vignette edges on screen wipes (like when you shoot the moon in hearts). Instead, it's a sharp edge moving across the screen. Even the "Last" and "Pass" boxes are distorted in the width in the new version.

These all under the same hardware and OS (10.4.6). The older versions are smooth. The new, ratty, jerky, uneven and loss of graphic detail.

Was there a new graphic engine brought into the code?

Thanks.

Edit: Ah, caught me writing while you were posting. I did also try downloading the games fresh rather than using the patched versions. Same results. Mac is a G5 dual 2 Ghz. Graphics card is an ATI Radeon 9600 XT. All software is up to date.

Kurt Lang
Active Poster
Posts: 35
Joined: Fri Dec 03, 2004 12:51 pm

More info.

Post by Kurt Lang » Wed Jun 28, 2006 2:23 pm

Hi Manny,

Just thought a little more info might help. I just updated to 10.4.7. No change in the graphics. I was kind of hoping something would change since part of that update is the ATI and nVidia drivers.

I also tried removing all preference and application support files in case old info was throwing off how the game displayed the graphics. Again, no change.

It seems that the problem started in whichever build introduced the question on the first time run of "if you could see the graphics in the background". I'm guessing you started using a different method of rendering the graphics for the games. As mentioned, all new versions display card movement and other animations poorly. The builds I have just before the change in graphics rendering are smooth.

Found another bug in the latest version of Hearts. The partneship option cannot be turned off. Doesn't matter if you select something else, or just turn it off and click OK. You end up playing partners anyway. No matter how many times you go back to the rules page, partnership is always turned back on.

User avatar
Manny
Active Poster
Posts: 346
Joined: Tue Nov 26, 2002 11:25 am
Location: Grants Pass, Oregon
Contact:

Post by Manny » Fri Sep 01, 2006 4:06 pm

This backgammon bug is finally fixed in Build 18.

Kurt Lang
Active Poster
Posts: 35
Joined: Fri Dec 03, 2004 12:51 pm

Post by Kurt Lang » Thu Sep 28, 2006 9:22 am

Yup. That seems to have done it. Thanks.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest