Page 1 of 1

OS X 10.4.7 workaround if the game is locking up

Posted: Wed Jun 28, 2006 4:48 pm
by Manny
Hardware mode is locking up our intel Mac in a bad unkillable way since the 10.4.7 update. The workaround is to disable hardware mode. Since the game is locked up, this has to be done manually. We'll get this sorted out as soon as we can and hopefully address some of those other issues, too.

From your home folder, dig through the following folders:

Library
Application Support
Silver Creek Entertainment

In that folder will be a folder for each game, for example "Hardwood Hearts".

In the game folder, finally, is the file "GlobalOptions.dna"

Open it with TextEdit or somesuch and find the line "HardwareMode=1"

Change the 1 to a 0, so the line reads "HardwareMode=0"

If the default hardware mode test hasn't run yet, such as a new install, you may need to add the following line to prevent it from trying to turn hardware mode back on:
"DefaultEnhancedModeTest.Build=100"

You can tell by whether there's already a similar line (with the game's current build number) in the GlobalOptions.dna file.

Hardwood Solitaire III & Mac OSX v.10.4.7

Posted: Thu Jun 29, 2006 8:41 pm
by connie-m
I tried the work around...couldn't find "Hardware=1" but did find "HardwareMode=1" so changed the 1 to 0. Result: no more freezing the computer, but solitaire won't open. Nothing happens.
There was also a line, "Hardware.RanOk=1". Should I change that instead? I tried changing both but nothing happened, am reluctant to change the first one back as I don't want another crash.

Posted: Thu Jun 29, 2006 11:55 pm
by Jonas
Have you tried the ComboUpdater?
http://www.apple.com/support/downloads/ ... intel.html

I read that there we're some Graphics related files missing in the basic update, but if you use the ComboUpdater it has the extra stuff. Might help.

Let us know if it does.

Posted: Fri Jun 30, 2006 3:30 am
by mwalpole
Followed the advice and seems to be working now. Not actually played the game yet but it does load up now.

OS X 10.4.7 workaround if the game is locking up

Posted: Fri Jun 30, 2006 4:53 am
by connie-m
I downloaded the OSX 10.4.7 Combo updater and now my game is working fine. Thanks!!

Posted: Fri Jun 30, 2006 12:06 pm
by Jonas
Hrmm, it didn't help on our system. Maybe it was the fact that you set the HW off in the file that actaully fixed it. :/

I guess you could try settin the HW mode back on and see if it still works.

Quite the mystery.

Posted: Fri Jun 30, 2006 5:35 pm
by connie-m
You are right. When I changed the Hardware Mode back to 1, it froze again. Guess you need both: hardware mode at 0 and the "fix" for the upgrade.

Posted: Sat Jul 01, 2006 7:41 am
by mwalpole
I stil have a problem with it. As I reported before the game loads up but last night when I actually played the game the checkers were flashing and in some instances not visible at all.

Solitaire and computer freeze up.

Posted: Sat Jul 01, 2006 10:42 am
by mrkachina
I have tried reloading the new osx upgrade. The game will not open and the mac freezes.
I tried the work around. It did not work.
I went back and redid everything again. Nothing.
I have taken Solitaire III off the desktop until you all come up with something that will work.

PS I downloaded a couple of other Solitaire programs which will work, but are certainly not the quality of Hardwood.

Waiting in the wings,

Jack Frazier

workaround

Posted: Mon Jul 03, 2006 11:09 pm
by sandis
after I downloaded the apple update and changed hardware mode from 1 to 0, the program no longer froze the computer; Instead, it just won't open.
this is almost as much fun as playing solitaire. (just kidding)

Same problem.

Posted: Tue Jul 04, 2006 12:43 pm
by Barry
Made the changes on my mac book and now it doesnt even load....

Posted: Wed Jul 05, 2006 1:25 pm
by Manny
I updated the notes earlier to reflect the correct option, "HardwareMode". (Thanks connie-m)

Today, I also corrected the file name, it's "GlobalOptions.dna", with an "s"

I also added a note about avoiding the hardware mode test, which can automacially enable hardware mode if the test hadn't been run before. If setting "HardwareMode=0" didn't work for you, then adding the additional line may work. (see above) Solitaire is working fine here with HardwareMode=0

The problem appears to be a bug in texture uploading since the update. I've yet to find an effective workaround other than disabling hardware mode. I have written to Apple, hopefully they'll be able to identify what's going wrong here, but I haven't heard back yet, likely because of the holiday.

Posted: Tue Jul 11, 2006 12:00 pm
by Manny
Just a quick update.

We've contacted Apple Developer Support, they were able to confirm the problem but didn't have a workaround either.

Now we're in contact with the Bug tracking folks at Apple.

Unfortunately, without a workaround for the problem, we can't really put out a fixed build without simply disabling hardware support.

Posted: Tue Jul 18, 2006 4:07 am
by mwalpole
Is there any update on this?